Omatic Cloud Login - 53375

Incident Report for Omatic Cloud

Resolved

The Omatic team confirms all known impacted users have successfully used the workaround. The issue with extra pop-up windows on Omatic Cloud logins is resolved.

For more detail, please contact Omatic Support through normal methods.
Posted Mar 12, 2025 - 17:13 EDT

Monitoring

Omatic engineers have identified an issue with Login Pages affecting the Omatic Cloud Web UI resulting in extra prompts during the login process.

Users may be prompted to enter their Organization during login. There was maintenance done to Omatic Cloud that changed a piece of the login flow.

The team has identified a WORKAROUND:

For one time only, you will need to enter your company as seen in your Omatic cloud subdomain in the box that says “Enter your Organization Name”. For example, http://[org_name].omaticcloud.com The bracketed text is what need to put into the text box. This is only impacting some users so if you are not seeing this, please disregard.

Updates are expected twice daily or on a change of status.

For more detail, you can subscribe to updates or contact Omatic Support through normal methods.
Posted Mar 12, 2025 - 15:44 EDT

Identified

Omatic engineers have identified an issue with Login Pages affecting the Omatic Cloud Web UI resulting in extra prompts during the login process.

Users may be prompted to enter their Organization during login. There was maintenance done to Omatic Cloud that changed a piece of the login flow.

The team has identified a WORKAROUND:

For one time only, you will need to enter your company as seen in your Omatic cloud subdomain in the box that says “Enter your Organization Name”. For example, http://[org_name].omaticcloud.com The bracketed text is what need to put into the text box. This is only impacting some users so if you are not seeing this, please disregard.

Updates are expected twice daily or on a change of status.

For more detail, you can subscribe to updates or contact Omatic Support through normal methods.
Posted Mar 12, 2025 - 10:40 EDT
This incident affected: Omatic Cloud (Omatic Cloud US, Omatic Cloud UK, Omatic Cloud AUS, Omatic Cloud CA).